Smite XBOX Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
The issue with #Smite #Xbox has been resolved.
Posted Jun 27, 2017 - 21:35 EDT
Monitoring
We have implemented a fix for the issue in #Smite #Xbox and are monitoring the results.
Posted Jun 27, 2017 - 20:25 EDT
Identified
We are performing an emergency restart of #Smite #Xbox. The game will be up shortly.
Posted Jun 27, 2017 - 20:09 EDT
Investigating
Automated services have detected a possible problem with #SMITE XBOX. We are investigating.
Posted Jun 27, 2017 - 19:59 EDT
This incident affected: SMITE (SMITE Xbox).