Smite PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
A data center connectivity issue caused impact to game servers; has now been resolved
Posted over 1 year ago. Feb 23, 2016 - 14:40 EST
Investigating
Automated services have detected a possible problem with #SMITE PC. We are investigating.
Posted over 1 year ago. Feb 23, 2016 - 13:45 EST