Turning Clash On
Incident Report for Hi-Rez Studios, Inc
Resolved
Logins have resumed and Clash has been enabled
#SMITE
Posted about 1 year ago. Feb 15, 2016 - 09:31 EDT
Investigating
We will be pausing xbox logins momentarily to turn Clash on.
Sorry for the inconvenience.
#SMITE
Posted about 1 year ago. Feb 15, 2016 - 09:23 EDT