Smite XBOX Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
The issues pertaining to some recent disconnects on #Smite #XBox have been resolved.
Posted about 1 year ago. Apr 21, 2016 - 23:43 EDT
Investigating
Automated services have detected a possible problem with #SMITE XBOX. We are investigating.
Posted about 1 year ago. Apr 21, 2016 - 23:23 EDT