Paladins PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted almost 2 years ago. Feb 11, 2016 - 17:49 EST
Update
We are investigating #paladins
Posted almost 2 years ago. Feb 11, 2016 - 17:38 EST
Update
Paladins PC has lost connection to some of our key components, we are working to resolve the issue and restore all services.
We will advise with more information at the appropriate time.
#PALADINS
Posted almost 2 years ago. Feb 11, 2016 - 17:37 EST
Investigating
Automated services have detected a possible problem with #Paladins PC. We are investigating.
Posted almost 2 years ago. Feb 11, 2016 - 17:35 EST