Smite PS4 Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
Resolved: This Smite PS4 incident has been resolved#smite
Posted over 1 year ago. Apr 18, 2016 - 13:52 EDT
Monitoring
Monitoring: A fix has been implemented for Smite PS4 and we are monitoring the results#smite
Posted over 1 year ago. Apr 18, 2016 - 13:43 EDT
Identified
We are going to be restarting Smite PS4 now#smite
Posted over 1 year ago. Apr 18, 2016 - 13:18 EDT
Update
Investigating: We are currently investigating this Smite PS4 issue#smite
Posted over 1 year ago. Apr 18, 2016 - 13:09 EDT
Investigating
Automated services have detected a possible problem with #SMITE PS4. We are investigating.
Posted over 1 year ago. Apr 18, 2016 - 13:06 EDT