Paladins Emergency Maintainance
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted 25 days ago. Apr 04, 2017 - 10:26 EDT
Monitoring
Logins have been enabled. We are monitoring.
Posted 25 days ago. Apr 04, 2017 - 10:16 EDT
Investigating
We are currently working on issues with Paladins PC.
Posted 25 days ago. Apr 04, 2017 - 10:03 EDT
This incident affected: Paladins PC.