Smite PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This is now resolved. We apologize for any inconvenience.
Posted 24 days ago. Apr 05, 2017 - 15:34 EDT
Monitoring
Issue is currently resolved , we will monitor for a period of time.
Posted 24 days ago. Apr 05, 2017 - 14:38 EDT
Investigating
Automated services have detected a possible problem with #SMITE PC. We are investigating.
Posted 24 days ago. Apr 05, 2017 - 14:33 EDT