Smite PC Emergency Restart
Incident Report for Hi-Rez Studios, Inc
Resolved
Logins are returning to normal; game is stable; #SmitePC restart is complete.
Posted 3 months ago. Mar 15, 2017 - 00:36 EDT
Monitoring
restart of #SmitePC is complete and logins are enabled; we are continuing to monitor
Posted 3 months ago. Mar 15, 2017 - 00:17 EDT
Identified
we will be performing an emergency restart of #SmitePC; game back shortly
Posted 3 months ago. Mar 14, 2017 - 23:57 EDT
This incident affected: Smite PC - North America / Europe.