HiRez Login Issues
Incident Report for Hi-Rez Studios, Inc
Resolved
We have resolved the issue with the HiRez Launcher
Posted over 1 year ago. Mar 24, 2017 - 11:32 EDT
Investigating
We are currently looking into issues with the HiRez Launcher
Posted over 1 year ago. Mar 24, 2017 - 11:30 EDT
This incident affected: Smite (Smite PC), Paladins (Paladins PC), Hand of the Gods (Hand of the Gods PC), and Hi-Rez Studios (Hi-Rez Public APIs).