Billing System Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
The #Paladins #PC web store is back up, and the issue has been resolved.
Posted Jun 21, 2018 - 09:27 EDT
Update
We are continuing to investigate an issue with the #Paladins #PC web store. However, the #Smite and #HotG #PC web stores are back up.
Posted Jun 21, 2018 - 09:00 EDT
Investigating
We are investigating an issue with our billing system for #Smite, #Paladins, and #HotG #PC.
Posted Jun 21, 2018 - 08:43 EDT
This incident affected: SMITE (SMITE PC) and Paladins (Paladins PC).