Hirez Games possible issue
Incident Report for Hi-Rez Studios, Inc
Resolved
#HiRez Games experienced a brief connectivity issue that impacted ALL non-mobile products (#Smite #Paladins #Tribes); players might have to re-login but we are recovering normally; apologies for the inconvenience.
Posted over 1 year ago. May 25, 2016 - 18:43 EDT
Investigating
Automated services have detected a possible problem our Atlanta servers and may affect all games. #SMITE #Tribes #Paladins. We are investigating.
Posted over 1 year ago. May 25, 2016 - 18:34 EDT