Smite PC and Xbox Servers Down
Incident Report for Hi-Rez Studios, Inc
Resolved
All games are operational.
Posted almost 2 years ago. Oct 04, 2015 - 22:14 EDT
Update
Smite PC and Xbox Servers are down. We are aware of the situation and are currently investigating the problem. Check back later for updates.
Posted almost 2 years ago. Oct 04, 2015 - 19:45 EDT
Investigating
We are currently investigating this issue.
Posted almost 2 years ago. Oct 04, 2015 - 19:44 EDT