Paladins PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This was only a test- Paladins PC is operational.
Posted almost 2 years ago. Feb 06, 2016 - 13:11 EST
Investigating
Automated services have detected a possible problem with #Paladins PC. We are investigating.
Posted almost 2 years ago. Feb 06, 2016 - 13:09 EST