Smite XBOX Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
#SMITE #XBox has been restarted. We are continuing to monitor...all systems look stable.
Posted 6 months ago. Dec 12, 2016 - 22:21 EST
Update
We will be performing an emergency restart on #Smite for #Xbox.
We apologize for the inconvenience.
Posted 6 months ago. Dec 12, 2016 - 21:48 EST
Identified
We have identified the issue with #SMITE XBox and are working to resolve...more updates to follow.
Posted 6 months ago. Dec 12, 2016 - 21:39 EST
Update
Experiencing issue with #SMITE XBox. Investigating.
Posted 6 months ago. Dec 12, 2016 - 21:25 EST
Investigating
Automated services have detected a possible problem with #SMITE XBOX. We are investigating.
Posted 6 months ago. Dec 12, 2016 - 21:17 EST