Paladins PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
Resolved: This paladins incident has been resolved. #paladins
Posted 10 months ago. Oct 15, 2016 - 14:06 EDT
Update
We are currently suspending paladins logins for a few minutes#paladins
Posted 10 months ago. Oct 15, 2016 - 13:49 EDT
Investigating
Automated services have detected a possible problem with #Paladins PC. We are investigating.
Posted 10 months ago. Oct 15, 2016 - 13:39 EDT