Paladins PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted 7 months ago. Oct 22, 2016 - 15:31 EDT
Identified
We are currently working to resolve issues involving match making in #Paladins
Posted 7 months ago. Oct 22, 2016 - 15:04 EDT
Investigating
Automated services have detected a possible problem with #Paladins PC. We are investigating.
Posted 7 months ago. Oct 22, 2016 - 14:56 EDT