Paladins PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
Logins for #Paladins #PC have resumed.
Posted 8 days ago. May 18, 2017 - 13:40 EDT
Identified
We are looking into issue with Queues on Paladins PC.
Posted 8 days ago. May 18, 2017 - 13:28 EDT
Investigating
Automated services have detected a possible problem with #Paladins PC. We are investigating.
Posted 8 days ago. May 18, 2017 - 13:25 EDT
This incident affected: Paladins PC.