Realm Royale Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted Jun 15, 2018 - 13:06 EDT
Monitoring
The restart has been completed and servers are back up! We are continuing to watch the situation.
Posted Jun 15, 2018 - 12:07 EDT
Identified
WE are performing an emergency restart for Realm Royale.
Posted Jun 15, 2018 - 11:40 EDT
Update
We are limiting logins for Realm Royale while we continue to investigate.
Posted Jun 15, 2018 - 11:28 EDT
Investigating
We are investigating an Issue affecting Logins for Realm Royale.
Posted Jun 15, 2018 - 11:22 EDT
This incident affected: Realm Royale Reforged (Realm Royale PC).