Paladins PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted 11 months ago. Dec 22, 2016 - 16:57 EST
Identified
We are currently working on issues with #PALADINS.
Posted 11 months ago. Dec 22, 2016 - 16:45 EST
Investigating
Automated services have detected a possible problem with #Paladins PC. We are investigating.
Posted 11 months ago. Dec 22, 2016 - 16:29 EST
This incident affected: Paladins PC.