Smite PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted about 2 months ago. Feb 03, 2017 - 22:47 EDT
Monitoring
We are continuing to monitor #Smite on #PC
Posted about 2 months ago. Feb 03, 2017 - 21:21 EDT
Identified
We will be performing an emergency restart of #Smite on #PC
Posted about 2 months ago. Feb 03, 2017 - 20:57 EDT
Investigating
Automated services have detected a possible problem with #SMITE PC. We are investigating.
Posted about 2 months ago. Feb 03, 2017 - 20:51 EDT
This incident affected: Smite PC - North America / Europe.