Login Issues For Smite PC, Smite Xbox, and Tribes Ascend
Incident Report for Hi-Rez Studios, Inc
Resolved
All network issues are resolved, games are operational.
Posted about 2 years ago. Nov 01, 2015 - 05:07 EST
Identified
The network problems appear to be over, we are checking the systems. Smite PC Is tentatively back up, Xbox being looked at
Posted about 2 years ago. Nov 01, 2015 - 04:52 EST
Investigating
Currently experiencing issues with Logging in to all enviroments... we are looking into it
Posted about 2 years ago. Nov 01, 2015 - 04:19 EST