Smite PS4 Login issues
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted 6 months ago. Oct 21, 2016 - 18:10 EDT
Identified
Sony's PSN network is experiencing problems, PS4 users may have issues logging in#smitePS4
Posted 6 months ago. Oct 21, 2016 - 12:52 EDT