Trouble logging into paladina
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted almost 2 years ago. Jan 27, 2016 - 14:14 EST
Investigating
May have trouble logging into Paladins PC for up to the next 1hr
Posted almost 2 years ago. Jan 27, 2016 - 11:03 EST