Smite PS4 Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted about 1 month ago. Apr 14, 2017 - 18:20 EDT
Monitoring
We are currently monitoring Smite PS4. Game is up for logins.
Posted about 1 month ago. Apr 14, 2017 - 17:50 EDT
Identified
We are currently working on the issues with Smite PS4. #SMITE #PS4
Posted about 1 month ago. Apr 14, 2017 - 17:36 EDT
Investigating
Automated services have detected a possible problem with #SMITE PS4. We are investigating.
Posted about 1 month ago. Apr 14, 2017 - 17:33 EDT
This incident affected: Smite PS4 - North America / Europe.