Smite XBOX Pausing Logins
Incident Report for Hi-Rez Studios, Inc
Resolved
You are now able to login to smite-xbox normally.
#SMITE
Posted over 1 year ago. Mar 03, 2016 - 18:59 EST
Investigating
We will be pausing logins on smite-xbox for a small amount of time.
Sorry for the inconvenience.
#SMITE
Posted over 1 year ago. Mar 03, 2016 - 18:45 EST