Tribes PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
The issue with #TribesPC has been resolved.
Posted 6 months ago. Mar 20, 2017 - 17:19 EDT
Monitoring
We have resolved the issue with #TribesPC; we are continuing to monitor
Posted 6 months ago. Mar 20, 2017 - 17:09 EDT
Update
We are continuing to try and resolve the issue. #TribesPC
Posted 6 months ago. Mar 20, 2017 - 16:56 EDT
Identified
We are working to resolve the incident #TribesPC
Posted 6 months ago. Mar 20, 2017 - 16:27 EDT
Investigating
Automated services have detected a possible problem with #Tribes PC. We are investigating.
Posted 6 months ago. Mar 20, 2017 - 16:24 EDT
This incident affected: Tribes Ascend.