Hirez Games possible issue
Incident Report for Hi-Rez Studios, Inc
Resolved
all games are back to normal. #SMITE #Tribes #Paladins
Posted over 1 year ago. Mar 06, 2016 - 21:00 EST
Monitoring
We are monitoring a possible issue at problem from our Atlanta servers and may affect all games. #SMITE #Tribes #Paladins
Posted over 1 year ago. Mar 06, 2016 - 20:59 EST
Investigating
Automated services have detected a possible problem our Atlanta servers and may affect all games. #SMITE #Tribes #Paladins. We are investigating.
Posted over 1 year ago. Mar 06, 2016 - 20:56 EST