Hirez Games Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted 4 months ago. Nov 22, 2016 - 20:09 EDT
Investigating
Automated services have detected a possible patcher issue that may impact multiple games. We are investigating. #SMITE #Paladins
Posted 4 months ago. Nov 22, 2016 - 19:50 EDT