Smite PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This Smite PC incident has been resolved. #SmitePC
Posted 3 months ago. Feb 21, 2017 - 00:23 EST
Investigating
Automated services have detected a possible problem with #SMITE PC. We are investigating.
Posted 3 months ago. Feb 20, 2017 - 23:57 EST