Unscheduled SMITE PC Restart
Incident Report for Hi-Rez Studios, Inc
Resolved
SMITE PC is back up and taking players. Thank you for your patience. #SMITE
Posted almost 2 years ago. Sep 19, 2015 - 00:51 EDT
Identified
We are performing an unscheduled restart of SMITE PC; game will be back up shortly. Updates to follow.
Posted almost 2 years ago. Sep 19, 2015 - 00:36 EDT