Smite PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
Issue with #SMITE PC has been resolved; levels have normalized; apologies or the inconvenience
Posted 8 months ago. Jan 21, 2017 - 13:56 EST
Monitoring
We have addressed the issue with #SMITE PC; game is open for business; continuing to monitor
Posted 8 months ago. Jan 21, 2017 - 13:21 EST
Update
Ongoing issue with #SMITE PC; Staff still engaged and working to resolve
Posted 8 months ago. Jan 21, 2017 - 12:40 EST
Update
We are continuing to try to resolve an issue with #SMITE PC; game is still down but back up ASAP
Posted 8 months ago. Jan 21, 2017 - 12:16 EST
Update
Continued issue with #SMITE PC; we are still working to resolve
Posted 8 months ago. Jan 21, 2017 - 11:47 EST
Identified
Issues with #SMITE PC; we are working to resolve.
Posted 8 months ago. Jan 21, 2017 - 11:28 EST
Investigating
Automated services have detected a possible problem with #SMITE PC. We are investigating.
Posted 8 months ago. Jan 21, 2017 - 11:20 EST
This incident affected: Smite PC - North America / Europe.