Smite PC Logins limited
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted about 1 year ago. Feb 03, 2016 - 13:22 EDT
Investigating
We will be limiting logins to alleviate issues with matches launching.
#SMITE
Posted about 1 year ago. Feb 03, 2016 - 13:13 EDT