Smite XBOX Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted about 1 year ago. Feb 14, 2016 - 18:25 EDT
Monitoring
We are seeing possible issues with xbox-live services.
Will update when we have more information.
#SMITE
Posted about 1 year ago. Feb 14, 2016 - 18:00 EDT
Investigating
Automated services have detected a possible problem with #SMITE XBOX. We are investigating.
Posted about 1 year ago. Feb 14, 2016 - 17:55 EDT