Launcher showing as down on Smite PC
Incident Report for Hi-Rez Studios, Inc
Resolved
Resolved: This Smite PC incident has been resolved. #smitepc
Posted 3 months ago. Mar 14, 2017 - 07:13 EDT
Investigating
Currently the launcher is showing as Down for Smite PC, we are currently working on this. #Smitepc
Posted 3 months ago. Mar 14, 2017 - 07:02 EDT
This incident affected: Smite PC - North America / Europe.