Smite PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
The incident has been resolved for #Smite #PC
Posted 6 months ago. May 19, 2017 - 17:00 EDT
Update
Steam is currently experiencing Issues, that are causing issues with users logging into Smite PC
Posted 6 months ago. May 19, 2017 - 15:59 EDT
Investigating
Automated services have detected a possible problem with #SMITE PC. We are investigating.
Posted 6 months ago. May 19, 2017 - 15:53 EDT
This incident affected: Smite PC - North America / Europe.