Smite PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted 3 months ago. Apr 03, 2017 - 01:16 EDT
Monitoring
We are currently monitoring Smite PC.
Posted 3 months ago. Apr 03, 2017 - 01:08 EDT
Update
We are currently looking into issues with Smite PC
Posted 3 months ago. Apr 03, 2017 - 00:55 EDT
Investigating
Automated services have detected a possible problem with #SMITE PC. We are investigating.
Posted 3 months ago. Apr 03, 2017 - 00:49 EDT
This incident affected: Smite PC - North America / Europe.