Smite XBOX Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
We have recovered and are continuing to monitor.
Posted Jan 21, 2018 - 20:26 EST
Identified
We have identified the issue with #Smite #Xbox and are implementing a fix.
Posted Jan 21, 2018 - 20:23 EST
Investigating
Automated services have detected a possible problem with #SMITE XBOX. We are investigating.
Posted Jan 21, 2018 - 20:20 EST
This incident affected: SMITE (SMITE Xbox).