Realm Royale Login Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted 15 days ago. Jun 09, 2018 - 16:56 EDT
Monitoring
Players are now able to sign into the game with Steam. We will continue to monitor the situation.
Posted 15 days ago. Jun 09, 2018 - 16:21 EDT
Identified
We are currently experiencing issues with Steam. We are working on the situation.
Posted 15 days ago. Jun 09, 2018 - 14:58 EDT
Investigating
We are investigating the issue with Realm Royale Logins.
Posted 15 days ago. Jun 09, 2018 - 14:27 EDT
This incident affected: Realm Royale (Realm Royale PC).