Smite PS4 Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
The incident has been resolved for #Smite #PS4
Posted 6 days ago. May 20, 2017 - 01:27 EDT
Monitoring
#Smite #PS4 has recovered and we are continuing to monitor.
Posted 6 days ago. May 20, 2017 - 01:05 EDT
Identified
We are currently working to resolve issues involving logins on #Smite #PS4
Posted 6 days ago. May 19, 2017 - 23:48 EDT
Investigating
Automated services have detected a possible problem with #SMITE PS4. We are investigating.
Posted 6 days ago. May 19, 2017 - 23:44 EDT
This incident affected: Smite PS4 - North America / Europe.