Hirez Games possible issue
Incident Report for Hi-Rez Studios, Inc
Resolved
Resolved: This incident has been resolved.
Posted about 1 year ago. Mar 11, 2016 - 03:07 EST
Investigating
Automated services have detected a possible problem our Atlanta servers and may affect all games. #SMITE #Tribes #Paladins. We are investigating.
Posted about 1 year ago. Mar 10, 2016 - 23:43 EST