Smite Xbox pausing logins
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted about 1 year ago. Mar 17, 2016 - 16:32 EDT
Investigating
We will be pausing logins for smite on Xbox at 4:15 PM EST.
Apologies for the inconvenience.
#SMITE
Posted about 1 year ago. Mar 17, 2016 - 16:07 EDT