Paladins PC brief interruptions in logins / matches
Incident Report for Hi-Rez Studios, Inc
Resolved
Logins / matches on #Paladins PC have been returned to normal; again, we apologize for the inconvenience.
Posted 5 months ago. Nov 11, 2016 - 18:43 EDT
Identified
We will be pausing logins / matches on #Paladins PC for 10 minutes starting at 6:30pm EST (12:30am CET); everything will be back to normal shortly. We apologize for the inconvenience.
Posted 5 months ago. Nov 11, 2016 - 18:20 EDT