Smite XBOX Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted about 1 year ago. Feb 13, 2016 - 00:25 EDT
Monitoring
We are currently working to resolve some server stability issues.
#SMITE
Posted about 1 year ago. Feb 13, 2016 - 00:07 EDT
Investigating
Automated services have detected a possible problem with #SMITE XBOX. We are investigating.
Posted about 1 year ago. Feb 12, 2016 - 23:38 EDT