Hirez Games Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
We have recovered; apologies for the inconvenience.
Posted 3 months ago. Dec 14, 2016 - 14:56 EDT
Monitoring
Hirez Studios experienced a brief datacenter hiccup that momentarily impacted all products; some users are having to re-login as a result; we are recovering and continuing to monitor...
Posted 3 months ago. Dec 14, 2016 - 14:28 EDT
Investigating
Automated services have detected a possible data center issue that may impact all games. We are investigating. #SMITE #Paladins #Tribes
Posted 3 months ago. Dec 14, 2016 - 14:23 EDT