Smite PC Logins Pausing for a small amount of time
Incident Report for Hi-Rez Studios, Inc
Resolved
We have resolved this issue, and matches are now launching properly.
Sorry for the inconvenience.
#SMITE
Posted about 1 year ago. Feb 03, 2016 - 06:47 EST
Investigating
Investigating issues with matches not launching.
#SMITE
Posted about 1 year ago. Feb 03, 2016 - 06:34 EST