Paladins Performance Issues
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted 11 months ago. Oct 28, 2016 - 13:25 EDT
Investigating
We are currently working to resolve the issues effecting #Paladins.
We appreciate your patience.
Posted 11 months ago. Oct 28, 2016 - 12:25 EDT