Smite PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
the connectivity issue with #SMITE PC has been resolved; we have recovered
Posted 3 months ago. Feb 18, 2017 - 13:00 EST
Monitoring
we experienced a momentary connectivity issue with #SMITE PC; we are recovering and continuing to monitor
Posted 3 months ago. Feb 18, 2017 - 12:50 EST
Investigating
Automated services have detected a possible problem with #SMITE PC. We are investigating.
Posted 3 months ago. Feb 18, 2017 - 12:39 EST
This incident affected: Smite PC - North America / Europe.