Smite PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
Account creation issue with #SMITE PC has been resolved.
Posted 5 months ago. Nov 30, 2016 - 16:18 EST
Identified
Experiencing issues account creation on #SMITE PC; will be back up shortly.
Posted 5 months ago. Nov 30, 2016 - 15:41 EST
Investigating
Automated services have detected a possible problem with #SMITE PC. We are investigating.
Posted 5 months ago. Nov 30, 2016 - 15:21 EST