Smite XBOX Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
Resolved: This Smite Xbox incident has been resolved. #SmiteXbox
Posted 5 months ago. Feb 01, 2017 - 01:46 EST
Investigating
Automated services have detected a possible problem with #SMITE XBOX. We are investigating.
Posted 5 months ago. Jan 31, 2017 - 22:38 EST
This incident affected: Smite Xbox - North America / Europe.